Issues with payments and adding cards
Incident Report for LCN
Resolved
We're pleased to confirm that our payment provider has managed to resolve the recent issues with adding some payment cards and processing payments.

Any customers who continue to experience a problem, please get in touch so that we can investigate further.
Posted Oct 14, 2020 - 14:41 BST
Update
We're continuing to investigate issues affecting some customers when trying to add new payment cards or trying to process payment via the LCN website.

This appears to be an issue relating specifically to 3DSecure V2 and isn't affecting all customers/cards. Therefore, if you have service due to renewal, please get in touch via our support phone lines 01438 532 000 and we'll be able to process payment over the phone for you.

Sincere apologies once again for any inconvenience this may be causing.
Posted Oct 14, 2020 - 11:36 BST
Investigating
We're currently working with our payment gateway provider to identify the cause of issues some customers are experiencing with making payment and adding payment cards via the LCN website.

As soon as further information becomes available, updates will be added to this page.

Please accept our sincere apologies for any inconvenience this may be causing.
Posted Oct 08, 2020 - 15:55 BST
This incident affected: Payment platform.