Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 28, 2025 - 20:00 BST
Scheduled
A redundant pair of devices that support the Linux hosting environment will be under maintenance during this window. Only the inactive device will be worked upon, during this period there is increased risk to service as the inactive device of the pair will be unavailable to take over in event of a failure of the primary device.
Posted May 27, 2025 - 16:50 BST
This scheduled maintenance affected: Linux Hosting and FTP (Linux Hosting).